Basic Cisco IOS (Internetwork Operating System) Commands

Random Commands

router# no ip domain lookup ! prevents the 'Translating "whatever"...domain server (255.255.255.255)' message
router# show ip int bri ! show ip interfaces (brief version)
router# era sta ! "erase startup" configuration
router# show ver ! "show version" of operating system, etc
router# do show ip pro ! "show ip protocol"
router# no se pa ! "no secure-password" to unencrypt passwords
router# se pa ! "encrypt all passwords"
Assign IP Address:
router# int fa0/0
router# ip address 192.168.1.1 255.255.255.0
router# no shutdown ! enable interface
Enable RIP (Routing Information Protocol)
router# config t
router(config)# router rip
router(config)# default originate
router(config)# network 168.158.0.0
router(config)# exit
router# show ip route
router# no auto-sum // If you are using Rip v2
router# redistribute static // kind of like a relay agent - passes a static address to the next hop

Enable EIGRP

router# config t
router# router eigrp 1 // the "1" can be any unique number - but all routers that it is working with need the same number used on them too - this is an asynchronous service for the network.

Enable DHCP

router# config t
router(config)# ip dhcp pool HQ_Eth1
router(dhcp-config)# network 168.168.32.0 255.255.255.0
router(dhcp-config)# dns-server 210.100.100.1
router(dhcp-config)# default-router 168.158.32.1
router(dhcp-config)# exit
router(config)# ip dhcp excluded-address 168.158.32.1 168.158.32.10
Bypass Router Password if you don’t know it

// WARNING – This will reset the router to factory settings

  • Turn off the router
  • Right as you turn it back on (it is “Self decompressing the image,” start rapidly pressing the Ctrl and Break buttons together (if you are on a laptop without the Break button, instead, try using your Fn and Delete buttons (it worked for me).
  • The router should boot up into a recovery mode

Enter the following commands from here:

rommon 1 > confreg 0x2142
rommon 2 > reset
Now the router will reboot. Next, enter the following commands
Router> ena
Router# config t
Router(config)# configure-register 0x2102
Router(config)# enable secret newpassword
Now the router is back in your control

Run a command from any IOS level:

router# do show ip int bri ! the magic command is "do"
Write Router Commands
! copy running-config (in RAM) to the startup-config (in NVRAM (Non-Volatile RAM) so it works after reboot or crash
Router# copy running-config startup-config // (copy run start)

OR

router# write ! "wr" for short

Backup Router running-config to TFTP server:

router# copy run tftp ! copy "what" "where"
! all you need to know is the IP address

Erase Configuration to load new configuration:

router# erase startup

Restore NVRAM after erase startup:

router# reload

Restore Router running-config from TFTP server:

! first you must reconfigure the IP address for the router
router# copy tftp run ! copy "where" "what"

Erase Operating System from Router

router# copy flash tftp ! backup OS
! enter the filename of the OS (usually *.bin)

Restore OS to Router

router# copy tftp flash ! will be the same *.bin that you backed up

Verification Commands

router# show ip protocol
router# show running-config
router# show ip route
router# debug ip rip
router# debug all


Comments are closed.

Post Navigation